Email notification issue identified.

Incident Report for ElevatorZip

Update

Some users are not getting emails when new lead created, or lead assigned to them.
Posted May 27, 2025 - 13:48 UTC

Investigating

We are currently investigating this issue.
Posted May 27, 2025 - 13:46 UTC
This incident affects: ElevatorZip Core Application.